Investigate Zombieverter VCU GS450H Problem

Create a thread for each item that needs working on by the community
Post Reply
User avatar
Jack Bauer
Posts: 3560
Joined: Wed Dec 12, 2018 5:24 pm
Location: Ireland
Been thanked: 30 times
Contact:

Investigate Zombieverter VCU GS450H Problem

Post by Jack Bauer »

There have been several reports of a problem with the Lexus GS450H module in the Zombieverter VCU failing to provide smooth throttle response. e.g. here : viewtopic.php?p=48603#p48603

To date in order to solve this I purchased a GS450H drivetrain, removed it from d donor car, setup a test bench and got the firmware back into a working state on the DM_Work branch of the github repo here : https://github.com/damienmaguire/Stm32-vcu

Next, this system was fitted to my BMW E39 project :

and subsequently road tested at full (360v nominal) voltage without being able to observe this problem :


As I have a ton of projects on the go and am unable to reproduce the problem I am asking the greater openinverter community for assistance in diagnosing and fixing this problem in whatever form it takes. It has also been reported that older software does not have this problem so its at least 95% certain to be a software problem.

Requirements :

-Identify the root cause.
-Apply a fix
-Test the fix works in a vehicle
-Submit the fix on Github or on the forum so everyone can benefit and understand.
I'm going to need a hacksaw
User avatar
steveknox
Posts: 65
Joined: Mon Mar 11, 2019 9:36 am
Location: Bormley, UK
Contact:

Re: Investigate Zombieverter VCU GS450H Problem

Post by steveknox »

I'll be ready to do some road testing in the coming weeks. I was going to use the old VCU but i'll wire up the zombieverter instead and report back anything that I find.
et0
Posts: 115
Joined: Sun Oct 13, 2019 8:06 pm
Location: Scotland
Has thanked: 2 times
Been thanked: 1 time

Re: Investigate Zombieverter VCU GS450H Problem

Post by et0 »

Post Reply