When it is not possible to set up synchronization !

Post Reply
User avatar
alehandro
Posts: 45
Joined: Tue Dec 29, 2020 6:53 pm
Location: Belarus

When it is not possible to set up synchronization !

Post by alehandro »

I will leave this incomprehensible synchronization behavior here, when I find the reason, it will save someone time starting acquaintance with FOC. Now it's not solved yet and I'm looking for a reason.
I will describe the essence of the situation: You can never force the motor not to rotate when searching for the right sincofs in manual mode at 90-120A manualid from 0-65K, the rotor can only not rotate at low manualid 3-70A.
What has been tested or replaced:
1). Parameters and settings according to the YouTube video instructions of Johannes and Damien.
2). The conclusions of the resolver, generator/syn/cos are determined. There is an angle of 0-360.
3). Four resolver combinations have been tested, two of the four can rotate the motor
4). The Prius20 Inverter Has Been Replaced
5). Replaced the VCU with a new one, firmware 5.14 foc.
6). Replaced all the wiring with the screen, except for the power.
7). PWM and resolver generator signals are checked
8). Engine replaced
9). The synchronization range from 0 to 65k has been passed many times with an interval of 100-50 numbers

The problem continues to be relevant and in search of a solution, probably something insignificant, since everything has been replaced. These are not my first attempts at configuration, previously two sets were configured smoothly without difficulties, but not this time)
User avatar
johu
Site Admin
Posts: 3549
Joined: Thu Nov 08, 2018 10:52 pm
Location: Kassel/Germany
Contact:

Re: When it is not possible to set up synchronization !

Post by johu »

I can't spot any obvious fault either. How much is the resolver jitter, i.e. when you plot with 1000points/1000burst len what do you see?
Support R/D and forum on Patreon: https://patreon.com/openinverter - Subscribe on odysee: https://odysee.com/@openinverter:9
User avatar
alehandro
Posts: 45
Joined: Tue Dec 29, 2020 6:53 pm
Location: Belarus

Re: When it is not possible to set up synchronization !

Post by alehandro »

johu wrote: Sat Jun 25, 2022 8:10 pm I can't spot any obvious fault either. How much is the resolver jitter, i.e. when you plot with 1000points/1000burst len what do you see?
Attachments
Screenshot_20220625_180553_com.yandex.browser.jpg
Screenshot_20220625_180434_com.yandex.browser.jpg
Screenshot_20220625_180251_com.yandex.browser.jpg
User avatar
alehandro
Posts: 45
Joined: Tue Dec 29, 2020 6:53 pm
Location: Belarus

Re: When it is not possible to set up synchronization !

Post by alehandro »

johu wrote: Sat Jun 25, 2022 8:10 pm I can't spot any obvious fault either. How much is the resolver jitter, i.e. when you plot with 1000points/1000burst len what do you see?
Hello Johannes, yes, this incomprehensible synchronization behavior for me has become an obsessive goal to find a solution to the problem. The graphs seem quite logical to me. Today I even went the hard way in the "start" mode, checking the values of the syncofs with an interval of 300-100 numbers, the engine reacted differently to the throttle, but there was no smooth rotation on the entire segment from 0 to 65k and two combinations of the resolver where the rotor can rotate.
Post Reply